VS:ConvertToPolygon

From Vectorworks Developer
Revision as of 17:40, 13 August 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Converts object to polygon.

FUNCTION ConvertToPolygon(
h :HANDLE;
resolution :INTEGER) :HANDLE;
def vs.ConvertToPolygon(h, resolution):
    return HANDLE

Parameters

h HANDLE
resolution INTEGER

Example

PROCEDURE Example;
VAR
   h, h1 :HANDLE;
   res   :INTEGER;
BEGIN
   h := FSActLayer;
   IF h = NIL THEN
      AlrtDialog('You should select an object before running this script')
   ELSE BEGIN
      res := IntDialog('Enter resolution', '16');
      h1 := ConvertToPolygon(h, res);
   END;
END;
RUN(Example);

Version

Availability: from All Versions

This is drop-in function.