VS:ConvertToPolygon: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(wikify, thank you Raymond!)
 
Line 37: Line 37:
<remark>
<remark>
'''Notes:''' (RMullin - 2020 Mar 03)
'''Notes:''' (RMullin - 2020 Mar 03)
:1) Setting "resolution" higher creates more vertices. Magic numbers for "resolution" are [0, 8, 16, 32, 64, 128, 256, 512].
# Setting "resolution" higher creates more vertices. Magic numbers for "resolution" are [0, 8, 16, 32, 64, 128, 256, 512].
::Integer values between the numbers in this list generate duplicate results.
#: Integer values between the numbers in this list generate duplicate results.
::Values outside this range do not appear to affect the number of vertices generated.
#: Values outside this range do not appear to affect the number of vertices generated.
:
# This function creates a duplicate object, so you don't have to duplicate the object beforehand if you want to retain the original object.
:2) This function creates a duplicate object, so you don't have to duplicate the object beforehand if you want to retain the original object.
# If the original is selected, the duplicate will be selected, and vice versa.
:
 
:3) If the original is selected, the duplicate will be selected, and vice versa.
:
</remark>
</remark>



Latest revision as of 09:02, 3 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Converts object to polygon.

FUNCTION ConvertToPolygon(
h :HANDLE;
resolution :INTEGER) : HANDLE;
def vs.ConvertToPolygon(h, resolution):
    return HANDLE

Parameters

h HANDLE
resolution INTEGER

Remarks

Notes: (RMullin - 2020 Mar 03)

  1. Setting "resolution" higher creates more vertices. Magic numbers for "resolution" are [0, 8, 16, 32, 64, 128, 256, 512].
    Integer values between the numbers in this list generate duplicate results.
    Values outside this range do not appear to affect the number of vertices generated.
  2. This function creates a duplicate object, so you don't have to duplicate the object beforehand if you want to retain the original object.
  3. If the original is selected, the duplicate will be selected, and vice versa.

Version

Availability: from Vectorworks 2014