VS:ConvertToNURBS/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した図形をNURBS図形やNURBS図形のグループに変換します。

FUNCTION ConvertToNURBS(
h :HANDLE;
keepOrig :BOOLEAN) : HANDLE;
def vs.ConvertToNURBS(h, keepOrig):
    return HANDLE

Parameters

h HANDLE 図形のハンドル
keepOrig BOOLEAN 元図形を残す場合はTRUE

Example

PROCEDURE Example;
VAR
	h :handle;
BEGIN
	CallTool(-204);
	h := FSActLayer;
	h := ConvertToNURBS(h, false);
	h := CreateOffsetNurbsObjectHandle(h, 1);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks10.0