VS:ConvertToNURBS: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix note: SetPlanarRefIDToGround)
m (Transfer Orso to _c_)
 
Line 40: Line 40:


<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2010 Dec. 24) The orientation of the generated NURBS object is -like for extrudes- based on the active view. Set the plane of your profile object with [[VS:SetPlanarRefIDToGround]] if you need it planar.
[[User:CBM-c-|_c_]] (2010.12.24) The orientation of the generated NURBS object is -like for extrudes- based on the active view. Set the plane of your profile object with [[VS:SetPlanarRefIDToGround]] if you need it planar.
</remark>
</remark>



Latest revision as of 07:48, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function converts the input object into a new NURBS object or a group of NURBS objects in the document.

FUNCTION ConvertToNURBS(
h :HANDLE;
keepOrig :BOOLEAN) : HANDLE;
def vs.ConvertToNURBS(h, keepOrig):
    return HANDLE

Parameters

h HANDLE Handle of original object.
keepOrig BOOLEAN Leave the original object in the drawing.

Remarks

_c_ (2010.12.24) The orientation of the generated NURBS object is -like for extrudes- based on the active view. Set the plane of your profile object with VS:SetPlanarRefIDToGround if you need it planar.

Example

VectorScript

PROCEDURE Example;
VAR
h :HANDLE;
BEGIN
h := FSActLayer;
h := ConvertToNURBS(h, FALSE);
h := CreateOffsetNurbsObjectHandle(h, 1);
END;
RUN(Example);

Python

def Example():
	h = vs.FSActLayer()
	h = vs.ConvertToNURBS(h, False)
	h = vs.CreateOffsetNurbsObjectHandle(h, 1)
Example()

Version

Availability: from VectorWorks 10.0