VS:ConvertToArcPolyline

From Vectorworks Developer
Revision as of 09:44, 2 February 2022 by CBM-c- (talk | contribs) (add comment: this doesn't preserve existing rad and arc vertexes, the bloody thing!)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Convert, within a tolerance, the input polyline into an polyline that uses arcs for the curves.

FUNCTION ConvertToArcPolyline(
hPolygon :HANDLE;
dFuzz :REAL) : HANDLE;
def vs.ConvertToArcPolyline(hPolygon, dFuzz):
    return HANDLE

Parameters

hPolygon HANDLE
dFuzz REAL

Remarks

(_c_, 2022.02.02) Applied to polylines with mixed vertex types, this won't preserve existing arc vertexes: it only turns into arc beziers and cubic vertexes. Radius and arc vertexes will turn into corner!

Version

Availability: from Vectorworks 2014