VS:ConvertPosix2HSFPath

From Vectorworks Developer
Revision as of 03:43, 16 June 2016 by CBM-c- (talk | contribs) (fix typo)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Machintosh only!


Converts Posix (using '/' as delimiter) file path to HSF (using ':' as delimiter) file path.

FUNCTION ConvertPosix2HSFPath(
PosixPath :DYNARRAY[] of CHAR;
VAR outHSFPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertPosix2HSFPath(PosixPath):
    return (BOOLEAN, outHSFPath)

Parameters

PosixPath DYNARRAY[] of CHAR The Posix path that is to be converted.
outHSFPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'PosixPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed Posix path if the funtion fails.

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertHSF2PosixPath

VS Functions: [[VS:ConvertHSF2PosixPath]]