VS:ConvertPosix2HSFPath

From Vectorworks Developer
Revision as of 07:50, 16 June 2016 by CBM-c- (talk | contribs) (add remark)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

MacIntosh only!

Converts Posix (using '/' as delimiter) file path to HSF (using ':' as delimiter) file path.

FUNCTION ConvertPosix2HSFPath(
PosixPath :DYNARRAY[] of CHAR;
VAR outHSFPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertPosix2HSFPath(PosixPath):
    return (BOOLEAN, outHSFPath)

Parameters

PosixPath DYNARRAY[] of CHAR The Posix path that is to be converted.
outHSFPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'PosixPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed Posix path if the function fails.

Remarks

(Orso 2016.06.16): This doesn't fail easily (I never could see a failure) but will return gibberish upon anything but a qualified Posix path. Interestingly, passing a qualified HSF path (needing thus no conversion!) will also return gibberish:

Example:

path2convert := Macintosh HD:Users:atta2:Desktop:New File.txt
ConvertHSF2PosixPath(path2convert, path)
--> Macintosh HD:Users:user:Desktop:New File.txt > /Users/user/Desktop/New File.txt
--> OK
path2convert := /Users/atta2/Desktop/New File.txt { <-- this needs no conversion! }
ConvertHSF2PosixPath(path2convert, path)
--> /Users/user/Desktop/New File.txt > /:Users:user:Desktop:New File.txt
--> GIBBERISH

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertHSF2PosixPath

VS Functions: [[VS:ConvertHSF2PosixPath]]