VS:ConvertPosix2HSFPath: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix typo)
(add remark)
(2 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Machintosh only! <BR>
MacIntosh only!
<BR>
 
Converts Posix (using '/' as delimiter) file path to HSF (using ':' as delimiter) file path.</desc>
Converts Posix (using '/' as delimiter) file path to HSF (using ':' as delimiter) file path.
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 39: Line 40:
<return>
<return>
Returns true if the conversion succeeds. False if it fails.<BR>
Returns true if the conversion succeeds. False if it fails.<BR>
The resulted Posix path will be the same as the passed Posix path if the funtion fails.</return>
The resulted Posix path will be the same as the passed Posix path if the function fails.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.06.16): This doesn't fail easily (I never could see a failure) but will return gibberish upon anything but a qualified Posix path. Interestingly, passing a qualified HSF path (needing thus no conversion!) will also return gibberish:
 
Example:
path2convert := /Users/user/Desktop/New File.txt
ConvertPosix2HSFPath(path2convert, path)
--> /Users/user/Desktop/New File.txt > Macintosh HD:Users:user:Desktop:New File.txt
--> OK
 
path2convert := Macintosh HD:Users:user:Desktop:New File.txt { <-- this needs no conversion! }
ConvertPosix2HSFPath(path2convert, path)
--> Macintosh HD:Users:user:Desktop:New File.txt > :Macintosh HD/Users/user/Desktop/New File.txt
--> GIBBERISH
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:32, 16 June 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

MacIntosh only!

Converts Posix (using '/' as delimiter) file path to HSF (using ':' as delimiter) file path.

FUNCTION ConvertPosix2HSFPath(
PosixPath :DYNARRAY[] of CHAR;
VAR outHSFPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertPosix2HSFPath(PosixPath):
    return (BOOLEAN, outHSFPath)

Parameters

PosixPath DYNARRAY[] of CHAR The Posix path that is to be converted.
outHSFPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'PosixPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed Posix path if the function fails.

Remarks

(Orso 2016.06.16): This doesn't fail easily (I never could see a failure) but will return gibberish upon anything but a qualified Posix path. Interestingly, passing a qualified HSF path (needing thus no conversion!) will also return gibberish:

Example:

path2convert := /Users/user/Desktop/New File.txt 
ConvertPosix2HSFPath(path2convert, path)
--> /Users/user/Desktop/New File.txt > Macintosh HD:Users:user:Desktop:New File.txt
--> OK
path2convert := Macintosh HD:Users:user:Desktop:New File.txt { <-- this needs no conversion! }
ConvertPosix2HSFPath(path2convert, path)
--> Macintosh HD:Users:user:Desktop:New File.txt > :Macintosh HD/Users/user/Desktop/New File.txt
--> GIBBERISH

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertHSF2PosixPath

VS Functions: [[VS:ConvertHSF2PosixPath]]