VS:ConvertHSF2PosixPath

From Vectorworks Developer
Revision as of 03:44, 16 June 2016 by CBM-c- (talk | contribs) (fix typo)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Machintosh only!


Converts HSF (using ':' as delimiter) file path to Posix (using '/' as delimiter) file path.

FUNCTION ConvertHSF2PosixPath(
HSFPath :DYNARRAY[] of CHAR;
VAR outPosixPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertHSF2PosixPath(HSFPath):
    return (BOOLEAN, outPosixPath)

Parameters

HSFPath DYNARRAY[] of CHAR The HSF path that is to be converted.
outPosixPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'HSFPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed HSF path if the function fails.

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertPosix2HSFPath

VS Functions: [[VS:ConvertPosix2HSFPath]]