VS:ConvertHSF2PosixPath: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix typo)
(add remark)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Machintosh only!<BR>
MacIntosh only!
<BR>
 
Converts HSF (using ':' as delimiter) file path to Posix (using '/' as delimiter) file path.</desc>
Converts HSF (using ':' as delimiter) file path to Posix (using '/' as delimiter) file path.</desc>


Line 42: Line 42:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.06.16): This doesn't fail easily (I never could see a failure) but will return gibberish upon anything but a qualified Posix path. Interestingly, passing a qualified HSF path (needing thus no conversion!) will also return gibberish:
 
Example:
path2convert := Macintosh HD:Users:atta2:Desktop:New File.txt
ConvertHSF2PosixPath(path2convert, path)
--> Macintosh HD:Users:user:Desktop:New File.txt > /Users/user/Desktop/New File.txt
--> OK
 
path2convert := /Users/atta2/Desktop/New File.txt { <-- this needs no conversion! }
ConvertHSF2PosixPath(path2convert, path)
--> /Users/user/Desktop/New File.txt > /:Users:user:Desktop:New File.txt
--> GIBBERISH
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 07:51, 16 June 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

MacIntosh only!

Converts HSF (using ':' as delimiter) file path to Posix (using '/' as delimiter) file path.

FUNCTION ConvertHSF2PosixPath(
HSFPath :DYNARRAY[] of CHAR;
VAR outPosixPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertHSF2PosixPath(HSFPath):
    return (BOOLEAN, outPosixPath)

Parameters

HSFPath DYNARRAY[] of CHAR The HSF path that is to be converted.
outPosixPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'HSFPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed HSF path if the function fails.

Remarks

(Orso 2016.06.16): This doesn't fail easily (I never could see a failure) but will return gibberish upon anything but a qualified Posix path. Interestingly, passing a qualified HSF path (needing thus no conversion!) will also return gibberish:

Example:

path2convert := Macintosh HD:Users:atta2:Desktop:New File.txt
ConvertHSF2PosixPath(path2convert, path)
--> Macintosh HD:Users:user:Desktop:New File.txt > /Users/user/Desktop/New File.txt
--> OK
path2convert := /Users/atta2/Desktop/New File.txt { <-- this needs no conversion! }
ConvertHSF2PosixPath(path2convert, path)
--> /Users/user/Desktop/New File.txt > /:Users:user:Desktop:New File.txt
--> GIBBERISH

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertPosix2HSFPath

VS Functions: [[VS:ConvertPosix2HSFPath]]