VS:ConvertHSF2PosixPath: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (fix typo)
Line 31: Line 31:
outPosixPath
outPosixPath
DYNARRAY[] of CHAR
DYNARRAY[] of CHAR
Output parameter. Returns the converted path. If the funtion does not succeed the returned value is the passed 'HSFPath' value.
Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'HSFPath' value.
</line>
</line>
</lineList>
</lineList>
Line 39: Line 39:
<return>
<return>
Returns true if the conversion succeeds. False if it fails.<BR>
Returns true if the conversion succeeds. False if it fails.<BR>
The resulted Posix path will be the same as the passed HSF path if the funtion fails.</return>
The resulted Posix path will be the same as the passed HSF path if the function fails.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 03:44, 16 June 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Machintosh only!


Converts HSF (using ':' as delimiter) file path to Posix (using '/' as delimiter) file path.

FUNCTION ConvertHSF2PosixPath(
HSFPath :DYNARRAY[] of CHAR;
VAR outPosixPath :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.ConvertHSF2PosixPath(HSFPath):
    return (BOOLEAN, outPosixPath)

Parameters

HSFPath DYNARRAY[] of CHAR The HSF path that is to be converted.
outPosixPath DYNARRAY[] of CHAR Output parameter. Returns the converted path. If the function does not succeed the returned value is the passed 'HSFPath' value.

Return Value

Returns true if the conversion succeeds. False if it fails.

The resulted Posix path will be the same as the passed HSF path if the function fails.

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:ConvertPosix2HSFPath

VS Functions: [[VS:ConvertPosix2HSFPath]]