VS:Concat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (syn python)
m (Transfer Orso to _c_)
 
Line 34: Line 34:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]], 2015.05.23):  
[[User:CBM-c-|_c_]], 2015.05.23: You can use [[VS:Concat]] to convert numbers to strings, but it uses exclusively a dot "." as symbol for the decimal marker, it outputs the number as seen from inside VS. See the table below for a list of routines formatting according to your system's settings.
You can use [[VS:Concat]] to convert numbers to strings, but it uses exclusively a dot "." as symbol for the decimal marker, it outputs the number as seen from inside VS. See the table below for a list of routines formatting according to your system's settings.
{| class="wikitable"
{| class="wikitable"
|+ Decimal marker symbol usage
|+ Decimal marker symbol usage

Latest revision as of 06:14, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Concat combines, or concatenates, all the specified parameters in order and returns the resultant string.

FUNCTION Concat(
txt :DYNARRAY[] of CHAR) : DYNARRAY[] of CHAR;
def vs.Concat(txt):
    return DYNARRAY[] of CHAR

Parameters

txt DYNARRAY[] of CHAR

Remarks

_c_, 2015.05.23: You can use VS:Concat to convert numbers to strings, but it uses exclusively a dot "." as symbol for the decimal marker, it outputs the number as seen from inside VS. See the table below for a list of routines formatting according to your system's settings.

Decimal marker symbol usage
Metric: ',' American '.'
100,123
100.123
Formatting routines: Non formatting routines:
VS:Num2Str, VS:Num2StrF, VS:Angle2Str, VS:Area2Str, VS:Volume2Str
Num2Str(3, 100.123) { --> 100,123 on metric systems }
Num2Str(3, 100.123) { --> 100.123 on American systems }
VS:Concat
Concat(100.123) { --> 100.123 on any system }

Example

VectorScript

AlrtDialog(Concat('A', 'sample', 'string'));

Python

vs.AlrtDialog(vs.Concat('A', 'sample', 'string'))

Version

Availability: from All Versions