VS:CombinePolygons: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Same as AddSurface. Don&#039;t know what dFuzz is for.
Combines two polygons.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION CombinePolygons(hPolygonA :HANDLE; hPolygonB :HANDLE; dFuzz :REAL) :HANDLE;
FUNCTION CombinePolygons(hPolygonA:HANDLE; hPolygonB:HANDLE; dFuzz:REAL) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 39: Line 38:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
VAR
  h1, h2, h3 :HANDLE;
BEGIN
  CallTool(-207); h1 := FSActLayer;
  CallTool(-207); h2 := FSActLayer;
  h3 := CombinePolygons(h1, h2, 20);
END;
RUN(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|CombinePolygons]]
[[Category:VS Function Reference|CombinePolygons]]
[[Category:VS Function Reference:Objects - 2D|CombinePolygons]]
[[Category:VS Function Reference:Graphic Calculation|CombinePolygons]]

Latest revision as of 17:35, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Combines two polygons.

FUNCTION CombinePolygons(
hPolygonA :HANDLE;
hPolygonB :HANDLE;
dFuzz :REAL) : HANDLE;
def vs.CombinePolygons(hPolygonA, hPolygonB, dFuzz):
    return HANDLE

Parameters

hPolygonA HANDLE
hPolygonB HANDLE
dFuzz REAL

Version

Availability: from Vectorworks 2014