VS:Cloud

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Draws a cloud. Varies the billows of the clouds randomly between rMin and rMax. The hFactor is the height of each individual arc in the cloud.

FUNCTION Cloud(
h :HANDLE;
rMin :REAL;
rMax :REAL;
hFactor :REAL;
convex :BOOLEAN;
removeIntersections :BOOLEAN) :HANDLE;
def vs.Cloud(h, rMin, rMax, hFactor, convex, removeIntersections):
    return HANDLE

Parameters

h HANDLE
rMin REAL
rMax REAL
hFactor REAL
convex BOOLEAN
removeIntersections BOOLEAN

Example

PROCEDURE Example;
VAR
   h1, h2 :HANDLE; 
   minRad, maxRad, billowHgt :REAL; 
   convex, removeIntersections :BOOLEAN;
BEGIN
   CallTool(-204);
   h1 := FSActLayer;
   minRad := .5;
   maxRad := 2;
   billowHgt := .75;
   convex := true;
   removeIntersections := false;
   h2 := Cloud(h1, minRad, maxRad, billowHgt, convex, removeIntersections);
END;
Run(Example);

Version

Availability: from All Versions

This is drop-in function.