VS:Cloud: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(2 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Draws a cloud. Varies the billows of the clouds randomly between rMin and rMax. The hFactor is the height of each individual arc in the cloud.
Draws a cloud. Varies the billows of the clouds randomly between rMin and rMax. The hFactor is the height of each individual arc in the cloud.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION Cloud(h :HANDLE; rMin :REAL; rMax :REAL; hFactor :REAL; convex :BOOLEAN; removeIntersections :BOOLEAN) :HANDLE;
FUNCTION Cloud(h:HANDLE; rMin:REAL; rMax:REAL; hFactor:REAL; convex:BOOLEAN; removeIntersections:BOOLEAN) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 54: Line 53:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
VAR
  h1, h2 :HANDLE;
  minRad, maxRad, billowHgt :REAL;
  convex, removeIntersections :BOOLEAN;
BEGIN
  CallTool(-204);
  h1 := FSActLayer;
  minRad := .5;
  maxRad := 2;
  billowHgt := .75;
  convex := true;
  removeIntersections := false;
  h2 := Cloud(h1, minRad, maxRad, billowHgt, convex, removeIntersections);
END;
Run(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 17:35, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Draws a cloud. Varies the billows of the clouds randomly between rMin and rMax. The hFactor is the height of each individual arc in the cloud.

FUNCTION Cloud(
h :HANDLE;
rMin :REAL;
rMax :REAL;
hFactor :REAL;
convex :BOOLEAN;
removeIntersections :BOOLEAN) : HANDLE;
def vs.Cloud(h, rMin, rMax, hFactor, convex, removeIntersections):
    return HANDLE

Parameters

h HANDLE
rMin REAL
rMax REAL
hFactor REAL
convex BOOLEAN
removeIntersections BOOLEAN

Version

Availability: from Vectorworks 2014