VS:ClosestPoints/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision: 2014J VS Reference C)
 
(2 intermediate revisions by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVS/ja|specific=}}
{{LocationMain|category=LocationVS/ja|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 6: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the points on two objects where the shortest distance between those objects occurs. Should support all VW primitives, including polylines and NURBS. Would be nice if it supported groups, symbols, and PIOs. Would also be nice if it supported 3D.</desc>
二つのオブジェクト上のお互いに最も近接する点を返します。曲線とNURBSを含む全てのVW基本図形で動作するはず。グループ、シンボルやプラグインオブジェクトに対応することすることが望ましい。3Dも対応できるとよい。</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 61: Line 60:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
利用可能バージョン: Vectorworks 2014
Availability: from Vectorworks 2014


</version>
</version>

Latest revision as of 01:54, 16 January 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

二つのオブジェクト上のお互いに最も近接する点を返します。曲線とNURBSを含む全てのVW基本図形で動作するはず。グループ、シンボルやプラグインオブジェクトに対応することすることが望ましい。3Dも対応できるとよい。

PROCEDURE ClosestPoints(
h1 :HANDLE;
h2 :HANDLE;
VAR pt1 :VECTOR;
VAR pt2 :VECTOR;
VAR touching :BOOLEAN);
def vs.ClosestPoints(h1, h2):
    return (pt1, pt2, touching)

Parameters

h1 HANDLE
h2 HANDLE
pt1 VECTOR
pt2 VECTOR
touching BOOLEAN

Version

Availability: from Vectorworks 2014