VS:ClipSurface

From Vectorworks Developer
Revision as of 22:00, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new surface object by subtracting the intersection of surfaces s1 and s2 from s1.

PROCEDURE ClipSurface(
s1 :HANDLE;
s2 :HANDLE);

Parameters

s1 HANDLE Handle to object.
s2 HANDLE Handle to object.

Remarks

ClipSurface is not reliable if the smaller poly is not fully contained within the larger one.


Note that in the above example, PrevObj(h2); was used to get a handle to the clipped surface. Also note that checking the validity of this handle and possibly even its object type (polyline) or comparing it to the object being clipped (IF h3 <> h1), is necessary to check that the clipping operation was successful.

Example

PROCEDURE ClipSurfaceExample;
VAR
h1, h2, h3 :HANDLE;
BEGIN
DSelectAll;
CallTool(-203);
h1 := FSActLayer;
DSelectAll;
CallTool(-203);
h2 := FSActLayer;
ClipSurface(h1, h2);
h3 := PrevObj(h2);
IF h3 <> h1 THEN SetFPat(h3, 5);
END;
RUN(ClipSurfaceExample);

Version

Availability: from VectorWorks8.5