VS:ClipPolygon

From Vectorworks Developer
Revision as of 17:35, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Same as IntersectSurface, but improves performance by first checking to see if hClipper is within the bounding box of hPolygon before calling IntersectSurface.

FUNCTION ClipPolygon(
hPolygon :HANDLE;
hClipper :HANDLE;
dFuzz :REAL) : HANDLE;
def vs.ClipPolygon(hPolygon, hClipper, dFuzz):
    return HANDLE

Parameters

hPolygon HANDLE
hClipper HANDLE
dFuzz REAL

Version

Availability: from Vectorworks 2014