VS:ClipPolygon: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Same as IntersectSurface, but improves performance by first checking to see if hClipper is within the bounding box of hPolygon before calling IntersectSurface.

Not sure what dFuzz does.

Returns the handle of the result. Beware: if the clipping operation should have returned more than one polygon, only the first polygon will be returned.

FUNCTION ClipPolygon(
hPolygon :HANDLE;
hClipper :HANDLE;
dFuzz :REAL) :HANDLE;
def vs.ClipPolygon(hPolygon, hClipper, dFuzz):
    return HANDLE

Parameters

hPolygon HANDLE
hClipper HANDLE
dFuzz REAL

Remarks

I don't think that this works from inside Plug-in objects.

Example

PROCEDURE Example;
VAR
   h1, h2, h3 :HANDLE;
BEGIN
   CallTool(-204); h1 := FSActLayer;
   CallTool(-204); h2 := FSActLayer;
   h3 := ClipPolygon(h1, h2, 1);
END;
Run(Example);

Version

Availability: from All Versions

This is drop-in function.