VS:ClipPolygon: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Same as IntersectSurface, but improves performance by first checking to see if hClipper is within the bounding box of hPolygon before calling IntersectSurface.</desc>
Same as [[VS:IntersectSurface]], but improves performance by first checking to see if hClipper is within the bounding box of hPolygon before calling IntersectSurface.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 14:03, 13 March 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Same as VS:IntersectSurface, but improves performance by first checking to see if hClipper is within the bounding box of hPolygon before calling IntersectSurface.

FUNCTION ClipPolygon(
hPolygon :HANDLE;
hClipper :HANDLE;
dFuzz :REAL) : HANDLE;
def vs.ClipPolygon(hPolygon, hClipper, dFuzz):
    return HANDLE

Parameters

hPolygon HANDLE
hClipper HANDLE
dFuzz REAL

Version

Availability: from Vectorworks 2014