VS:ClearCavities

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ClearCavities resets the default cavity style of wall objects to no cavities.

PROCEDURE ClearCavities;
def vs.ClearCavities():
    return None

Example

VectorScript

DoubLines(6");
AddCavity(TRUE,1",2",2);
Wall(0,1,9,1);
ClearCavities;
Wall(0,2,11,2);
{creates a wall with a cavity, then creates a wall without a cavity}

Python

vs.DoubLines(6)
vs.AddCavity(True,1,2,2);
vs.Wall(0,1,9,1)
vs.ClearCavities()
vs.Wall(0,2,11,2)
#{creates a wall with a cavity, then creates a wall without a cavity}

Version

ClearCavities is obsolete as of VectorWorks12.5


Availability: from MiniCAD4.0