VS:CircularDim

From Vectorworks Developer
Revision as of 21:01, 5 August 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure CircularDim creates a diameter or radial dimension in a VectorWorks document.

Bit code values for dimension flags can be found in the VectorScript Appendix.

Circular Dimension

PROCEDURE CircularDim(
startPtX,startPtY :REAL;
endPtX,endPtY :REAL;
box1X,box1Y :REAL;
box2X,box2Y :REAL;
textOffsetDistance :REAL;
dimType :INTEGER;
arrow :INTEGER;
textFlag :INTEGER;
shoulder :REAL);
def vs.CircularDim(startPt, endPt, box1, box2, textOffsetDistance, dimType, arrow, textFlag, shoulder):
    return None

Parameters

startPt REAL X-Y coordinates of dimension start point.
endPt REAL X-Y coordinates of dimension end point.
box1 REAL X-Y coordinates of top left corner of object bounding box
box2 REAL X-Y coordinates of bottom right corner of object bounding box
textOffsetDistance REAL Offset distance of text from dimension line(witness leader length).
dimType INTEGER Dimension type flag.
arrow INTEGER Arrow style flag.
textFlag INTEGER Text style flag.
shoulder REAL Shoulder extension line length.

Example

VectorScript

CircularDim(-4 3/8",3",-4 3/8",1/4",-5 3/4",3",-3",1/4",1 1/8",1,3, 1025,1/4");

Python

vs.CircularDim(-4 - 3/8,3,-4 - 3/8,1/4,-5 - 3/4,3,-3,1/4,1 + 1/8,1,3, 1025,1/4)

Version

Availability: from All Versions