VS:Centroid3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION Centroid3D(object:HANDLE; VAR xCG:REAL; VAR yCG:REAL; VAR zCG:REAL) : BOOLEAN;
FUNCTION Centroid3D(obj:HANDLE; VAR xCG:REAL; VAR yCG:REAL; VAR zCG:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.Centroid3D(object):
def vs.Centroid3D(obj):
     return (BOOLEAN, xCG, yCG, zCG)
     return (BOOLEAN, xCG, yCG, zCG)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The objectt from whci to calculate the center of gravity
The objectt from whci to calculate the center of gravity

Revision as of 19:55, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the center of gravity of a 3D object. The function returns TRUE if the values were found.

FUNCTION Centroid3D(
obj :HANDLE;
VAR xCG :REAL;
VAR yCG :REAL;
VAR zCG :REAL) : BOOLEAN;
def vs.Centroid3D(obj):
    return (BOOLEAN, xCG, yCG, zCG)

Parameters

obj HANDLE The objectt from whci to calculate the center of gravity
xCG REAL The x component of the center of gravity.
yCG REAL The y component of the center of gravity.
zCG REAL The z component of the center of gravity.

Return Value

Returns true if the function succeeds.

Version

Availability: from VectorWorks10.1