VS:Centroid3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the center of gravity of a 3D object. The function returns TRUE if the values were found.

FUNCTION Centroid3D(
object :HANDLE;
VAR xCG :REAL;
VAR yCG :REAL;
VAR zCG :REAL) : BOOLEAN;
def vs.Centroid3D(object):
    return (BOOLEAN, xCG, yCG, zCG)

Parameters

object HANDLE The objectt from whci to calculate the center of gravity
xCG REAL The x component of the center of gravity.
yCG REAL The y component of the center of gravity.
zCG REAL The z component of the center of gravity.

Return Value

Returns true if the function succeeds.

Version

Availability: from VectorWorks10.1