VS:Centroid

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the centroid of the object. Returns false if an unsupported object type is supplied.

FUNCTION Centroid(
h :HANDLE;
VAR x :REAL;
VAR y :REAL) : BOOLEAN;
def vs.Centroid(h):
    return (BOOLEAN, x, y)

Parameters

h HANDLE
x REAL
y REAL

Remarks

(_c_ 2016.04.18): This returns mm, so convert the values into current units:

IF Centroid(h, c.x, c.y) THEN BEGIN

       { centroid returns mm }
       c.x := c.x * GetPrefReal(152) / 25.4;

c.y := c.y * GetPrefReal(152) / 25.4; END;

Version

Availability: from Vectorworks 2014