VS:Centroid: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (fix example)
(One intermediate revision by the same user not shown)
Line 40: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.04.18): This returns mm, so convert the values into current units:
<code lang="vss">
IF Centroid(h, c.x, c.y) THEN BEGIN
        { centroid returns mm }
        c.x := c.x * GetPrefReal(152) / 25.4;
c.y := c.y * GetPrefReal(152) / 25.4;
END;
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 06:57, 18 April 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the centroid of the object. Returns false if an unsupported object type is supplied.

FUNCTION Centroid(
h :HANDLE;
VAR x :REAL;
VAR y :REAL) : BOOLEAN;
def vs.Centroid(h):
    return (BOOLEAN, x, y)

Parameters

h HANDLE
x REAL
y REAL

Remarks

(Orso 2016.04.18): This returns mm, so convert the values into current units:

IF Centroid(h, c.x, c.y) THEN BEGIN

       { centroid returns mm }
       c.x := c.x * GetPrefReal(152) / 25.4;

c.y := c.y * GetPrefReal(152) / 25.4; END;

Version

Availability: from Vectorworks 2014