VS:CallToolWithMode

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Activates the specified Vectorworks tool for a single use with the specified tool mode. After the tool has been used Vectorworks will revert back to the previously active tool.

PROCEDURE CallToolWithMode(
toolIndex :INTEGER;
modeGroup :LONGINT;
modeButton :LONGINT);
def vs.CallToolWithMode(toolIndex, modeGroup, modeButton):
    return None

Parameters

toolIndex INTEGER Vectorworks tool constant.
modeGroup LONGINT Index of the mode group
modeButton LONGINT Index of the button in the group.

Remarks

Changes the active tool to that specified by toolID. Waits until the user has executed the functionality of that tool, then switches back to the previously active tool & returns.

Version

Availability: from Vectorworks 2016