VS:CallToolByIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Similar to CallTool. Takes the internal ID of a tool ( Appendix )

FUNCTION CallToolByIndex(
toolIndex :INTEGER) : BOOLEAN;
def vs.CallToolByIndex(toolIndex):
    return BOOLEAN

Parameters

toolIndex INTEGER

Example

Vectorscript

Message( CallToolByIndex( -221 ) ) { activate locus tool, returns true if successful }

Python

vs.Message( vs.CallToolByIndex( -221 ) ) # activate locus tool, returns true if successful

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS Functions:
  • [[VS:CallTool]]
  • [[VS:CallToolByName]]