VS:BuildResourceListN2

From Vectorworks Developer
Revision as of 17:34, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Build a resource list from the specified file.

FUNCTION BuildResourceListN2(
type :INTEGER;
fullPath :DYNARRAY[] of CHAR;
VAR numItems :LONGINT;
useDefaultContent :BOOLEAN) : LONGINT;
def vs.BuildResourceListN2(type, fullPath, useDefaultContent):
    return (LONGINT, numItems)

Parameters

type INTEGER the type of resource to put in the list
fullPath DYNARRAY[] of CHAR The path to the file that provides the resources.
numItems LONGINT the number of items in the list built
useDefaultContent BOOLEAN determine if the list should contain default content

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:BuildResourceListN | VS:BuildResourceList | VS:BuildResourceList2

VS Functions:

[[VS:BuildResourceListN]] | [[VS:BuildResourceList]]

| [[VS:BuildResourceList2]]