VS:BreakWall/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

直前に作成された壁を、指定した位置と長さで切り欠きます。

PROCEDURE BreakWall(
offsetDistance :REAL)Coordinate); breakWidthDistance:REAL (Coordinate); right:BOOLEAN);
def vs.BreakWall(offsetDistance, breakWidthDistance, right):
    return None

Parameters

offsetDistance REAL (Coordinate) 壁の始点からの距離
breakWidthDistance REAL (Coordinate) 切り欠きの長さ
right BOOLEAN 切り欠きの位置(TRUE:右/FALSE:左)

Example

MoveTo(2,3);
WallTo(7,3);
BreakWall(3",1",True);
{creates a right hand 1" wall break 3" from the start of the wall}

Version

利用可能バージョン: MiniCAD4.0