VS:BreakWall

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BreakWall creates a break in a wall object on the left or the right at a specified offset location.

PROCEDURE BreakWall(
offsetDistance :REAL;
breakWidthDistance :REAL;
right :BOOLEAN);
def vs.BreakWall(offsetDistance, breakWidthDistance, right):
    return None

Parameters

offsetDistance REAL Offset distance from wall start.
breakWidthDistance REAL Width of wall break.
right BOOLEAN Left-right edge status of break.

Example

VectorScript

MoveTo(2,3);
WallTo(7,3);
BreakWall(3",1",True);
{creates a right hand 1" wall break 3" from the start of the wall}

Python

vs.MoveTo(2,3)
vs.WallTo(7,3)
vs.BreakWall(3,1,True)

Version

Availability: from MiniCAD4.0