VS:BeginText

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedures BeginText creates a new text object in a VectorWorks document. All text specified between calls to BeginText and EndText will be part of the new text object.

Text may be specified in single quotes, or variables may be used..

To specify the insertion point of the new text object, use TextOrigin.

PROCEDURE BeginText;
def vs.BeginText():
    return None

Example

VectorScript

{ Create a multiple line text object at 0,0 }
TextFont(GetFontID('Monaco'));
TextSize(24);
TextOrigin(0,0);
BeginText;
'This multiple line text block 
is in 24pt Monaco and was created
by a VectorScript.'
EndText;

Python

#{ Create a multiple line text object at 0,0 }
vs.TextFont(vs.GetFontID('Monaco'))
vs.TextSize(24)
vs.TextOrigin(0,0)
vs.BeginText()
'This multiple line text block 
is in 24pt Monaco and was created
by a VectorScript.'
vs.EndText()

Version

Availability: from All Versions