VS:BeginRoof/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

この手続きを実行してから、EndGroupが実行されるまでに作成された2次元図形を平面とする屋根を作成します。

PROCEDURE BeginRoof(
p1X :REAL;
p1Y :REAL;
p2X :REAL;
p2Y :REAL;
upslopeX :REAL;
upslopeY :REAL;
riseDistance :REAL)Coordinate); runDistance:REAL (Coordinate); miter:INTEGER; vertPart:REAL);
def vs.BeginRoof(p1, p2, upslope, riseDistance, runDistance, miter, vertPart):
    return None

Parameters

p1 REAL 屋根の座標軸の始点
p2 REAL 屋根の座標軸の終点
upslope REAL 勾配定義の開始点の座標
riseDistance REAL (Coordinate) 高さ
runDistance REAL (Coordinate) 水平距離
miter INTEGER 端部の形状
vertPart REAL 端部が垂直と水平の時の垂直の寸法

Example

BeginRoof(1,1,5,1,2,2,0.5,1,1,0);
  ClosePoly;
  Poly(1,1,3,1,3.5,2,4,1,5,1,5,5,1,5);
EndGroup;

Version

Availability: from MiniCAD4.0