VS:BeginMesh

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginMesh begins the efinition of a 3D mesh object in VectorWorks. Any 3D point or planar object call after BeginMesh will be included in the mesh object.

A mesh object allows the user to select and manipulate each vertex within its wire-frame model.

PROCEDURE BeginMesh;
def vs.BeginMesh():
    return None

Example

VectorScript

BeginMesh;
ClosePoly;
PenSize(1);
PenPat(2);
FillPat(0);
Poly3D(0',0',4' 0",4' 0",0',4' 0",4' 0",-4' 0",4' 0",0',-4' 0",4' 0");
Smooth(0);
Poly3D(0',0',0',4' 0",0',0',4' 0",-4' 0",0',0',-4' 0",0');
Smooth(0);
Poly3D(0',-4' 0",0',0',-4' 0",4' 0",0',0',4' 0",0',0',0');
Poly3D(4' 0",-4' 0",0',4' 0",-4' 0",4' 0",0',-4' 0",4' 0",0',-4' 0",0');
Poly3D(4' 0",0',0',4' 0",0',4' 0",4' 0",-4' 0",4' 0",4' 0",-4' 0",0');
Poly3D(0',0',0',0',0',4' 0",4' 0",0',4' 0",4' 0",0',0');
EndMesh;

Python

vs.BeginMesh()
vs.ClosePoly()
vs.PenSize(1)
vs.PenPat(2)
vs.FillPat(0)
vs.Poly3D(0, 0, 4*12, 4*12, 0, 4*12, 4*12, -4*12, 4*12, 0, -4*12, 4*12)
vs.Smooth(0)
vs.Poly3D(0*12,0*12,0*12,4*12 ,0*12,0*12,4*12 ,-4*12 ,0*12,0*12,-4*12 ,0*12)
vs.Smooth(0)
vs.Poly3D(0*12,-4*12 ,0*12,0*12,-4*12 ,4*12 ,0*12,0*12,4*12 ,0*12,0*12,0*12)
vs.Poly3D(4*12 ,-4*12 ,0*12,4*12 ,-4*12 ,4*12 ,0*12,-4*12 ,4*12 ,0*12,-4*12 ,0*12)
vs.Poly3D(4*12 ,0*12,0*12,4*12 ,0*12,4*12 ,4*12 ,-4*12 ,4*12 ,4*12 ,-4*12 ,0*12)
vs.Poly3D(0*12,0*12,0*12,0*12,0*12,4*12 ,4*12 ,0*12,4*12 ,4*12 ,0*12,0*12)
vs.EndMesh()

Version

Availability: from All Versions