VS:BeginMXtrd

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginMXtrd creates a multiple extrude object in a VectorWorks document. BeginMXtrd uses 2D object creation procedure calls to define the "template" for the object.

You should call EndMXtrd after the object creation procedures to complete the definition and generate the object in the document.

A multiple extrude object is a 3D object created from three or more 2D objects, which are used as defining shapes for the extruded object.

PROCEDURE BeginMXtrd(
startDistance :REAL;
endDistance :REAL);
def vs.BeginMXtrd(startDistance, endDistance):
    return None

Parameters

startDistance REAL Start distance from document ground plane.
endDistance REAL End distance from document ground plane.

Example

VectorScript

BeginMXtrd(0',1 363/512");
Rect(-125/128",1 113/512",375/512",375/512");
Rect(-25/32",1 113/512",275/512",375/512");
Rect(-75/128",1 113/512",325/1024",375/512");
Locus(-275/2048",125/128");
Rect(-75/128",1 113/512",325/1024",375/512");
Rect(-25/32",1 113/512",275/512",375/512");
Rect(-125/128",1 113/512",375/512",375/512");
EndMXtrd;

Python

vs.BeginMXtrd(0,1 + 363/512)
vs.Rect(-125/128,1 + 113/512,375/512,375/512)
vs.Rect(-25/32,1 + 113/512,275/512,375/512)
vs.Rect(-75/128,1 + 113/512,325/1024,375/512)
vs.Locus(-275/2048,125/128)
vs.Rect(-75/128,1 + 113/512,325/1024,375/512)
vs.Rect(-25/32,1 + 113/512,275/512,375/512)
vs.Rect(-125/128,1 + 113/512,375/512,375/512)
vs.EndMXtrd()

Version

Availability: from All Versions