VS:BeginGroupN/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision: 2014J VS Reference B)
 
(2 intermediate revisions by the same user not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVS/ja|specific=}}
{{LocationMain|category=LocationVS/ja|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 25: Line 24:
groupHandle
groupHandle
HANDLE
HANDLE
対象となるグループのハンドル。ハンドルがnilに初期化されている場合は新しいグループが作られる。
対象となるグループのハンドル。ハンドルがnilに初期化されている場合は新しいグループが作られます。
</line>
</line>
</lineList>
</lineList>
Line 50: Line 49:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
関連関数:
VS Functions:
[[VS:BeginGroup]]  
[[VS:BeginGroup]]  
| [[VS:EndGroup]]  
| [[VS:EndGroup]]  
Line 57: Line 56:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
利用可能バージョン: Vectorworks 2011
Availability: from Vectorworks 2011


</version>
</version>

Latest revision as of 01:42, 16 January 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

グループのハンドルを指定し、既存のグループに図形を作成して追加します。nilに初期化されたハンドルを渡した場合は新しいグループが作成されます。

PROCEDURE BeginGroupN(
VAR groupHandle :HANDLE);
def vs.BeginGroupN(groupHandle):
    return groupHandle

Parameters

groupHandle HANDLE 対象となるグループのハンドル。ハンドルがnilに初期化されている場合は新しいグループが作られます。

Example

BeginGroupN(groupHandle);
  Rect(-1,1,0.5,0);
EndGroup;
{ adds created rect to existing group }

groupHandle := nil;
BeginGroupN(groupHandle);
  Rect(-1,1,0.5,0);
EndGroup;
{ creates new group and adds created rect to created group }

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:BeginGroup | VS:EndGroup

VS Functions:

[[VS:BeginGroup]]

| [[VS:EndGroup]]