VS:BeginGroupN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

May be used to create objects in an existing group by passing a group handle; if a handle initialized to NIL is passed a new group is created.

PROCEDURE BeginGroupN(
VAR groupHandle :HANDLE);
def vs.BeginGroupN(groupHandle):
    return groupHandle

Parameters

groupHandle HANDLE The group handle to be used; if handle is initialized to NIL a new group is created.

Example

BeginGroupN(groupHandle);
  Rect(-1,1,0.5,0);
EndGroup;
{ adds created rect to existing group }

groupHandle := nil;
BeginGroupN(groupHandle);
  Rect(-1,1,0.5,0);
EndGroup;
{ creates new group and adds created rect to created group }

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:BeginGroup | VS:EndGroup

VS Functions:

[[VS:BeginGroup]]

| [[VS:EndGroup]]