VS:BeginFolderN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix example: syntax, use mentioned routine, not the old one)
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure BeginFolderN creates a new resource folder of the indicated type in a Vectorworks document. Any resource or folder of that type created after the current call to BeginFolderN will be nested inside the new folder. A call to EndFolder will complete the creation of the folder, which is then generated in the Vectorworks document.
Procedure BeginFolderN creates a new resource folder of the indicated type in a Vectorworks document. Any resource or folder of that type created after the current call to BeginFolderN will be nested inside the new folder. A call to [[VS:EndFolder| EndFolder]] will complete the creation of the folder, which is then generated in the Vectorworks document.


To name the new folder, precede BeginFolderN with a call to NameObject.<BR>
To name the new folder, precede BeginFolderN with a call to [[VS:NameObject| NameObject]].
</desc>
</desc>


Line 56: Line 56:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
* [[VS:EndFolder]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 67: Line 69:


[[Category:VS Function Reference|BeginFolderN]]
[[Category:VS Function Reference|BeginFolderN]]
[[Category:VS Function Reference:Objects - Groups|BeginFolderN]]
[[Category:VS Function Reference:Document List Handling|BeginFolderN]]

Latest revision as of 19:14, 4 January 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginFolderN creates a new resource folder of the indicated type in a Vectorworks document. Any resource or folder of that type created after the current call to BeginFolderN will be nested inside the new folder. A call to EndFolder will complete the creation of the folder, which is then generated in the Vectorworks document.

To name the new folder, precede BeginFolderN with a call to NameObject.

PROCEDURE BeginFolderN(
type :INTEGER);
def vs.BeginFolderN(type):
    return None

Parameters

type INTEGER the type of resource the folder will contain

Example

NameObject('Object Symbols');
BeginFolderN(16); { 16 = symbol definitions }
  BeginSym('Oval Symbols');
    PenSize(14);
    PenPat(2);
    FillPat(1);
    FillFore(0,0,0);
    FillBack(65535,65535,65535);
    PenFore(0,0,0);
    PenBack(65535,65535,65535);
    Oval(-1/4",1/4",3/4",-3/4");
  EndSym;
EndFolder;
{creates the symbol folder 'Object Symbols', which contains a symbol}

Version

Availability: from Vectorworks 2018

See Also

* VS:EndFolder

* [[VS:EndFolder]]