VS:BeginFolder

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginFolder creates a new symbol folder in a VectorWorks document. Any symbols or symbol folders created after the current call to BeginFolder will be nested inside the new symbol folder. A call to EndFolder will complete the creation of the symbol folder, which is then generated in the VectorWorks document.

To name the new symbol folder, precede BeginFolder with a call to NameObject.

PROCEDURE BeginFolder;
def vs.BeginFolder():
    return None

Example

VectorScript

NameObject('Object Symbols');
BeginFolder;
BeginSym('Oval Symbols');
PenSize(14);
PenPat(2);
FillPat(1);
FillFore(0,0,0);
FillBack(65535,65535,65535);
PenFore(0,0,0);
PenBack(65535,65535,65535);
Oval(-1/4",1/4",3/4",-3/4");
EndSym;
EndFolder;
{creates the symbol folder 'Object Symbols', which contains a symbol}

Python

vs.NameObject('Object Symbols')
vs.BeginFolder()
vs.BeginSym('Oval Symbols')
vs.PenSize(14)
vs.PenPat(2)
vs.FillPat(1)
vs.FillFore(0,0,0)
vs.FillBack(65535,65535,65535)
vs.PenFore(0,0,0)
vs.PenBack(65535,65535,65535)
vs.Oval(-1/4,1/4,3/4,-3/4)
vs.EndSym()
vs.EndFolder()

Version

Availability: from All Versions