VS:BeginDialog

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Initiates the custom dialog definition process. All VectorScript calls made between the BeginDialog and EndDialog will be used to construct a custom dialog.

PROCEDURE BeginDialog(
dialogID :INTEGER;
dialogType :INTEGER;
x1 :INTEGER;
y1 :INTEGER;
x2 :INTEGER;
y2 :INTEGER);
def vs.BeginDialog(dialogID, dialogType, x1, y1, x2, y2):
    return None

Parameters

dialogID INTEGER Unique identifier ID for dialog(in a range of 1-32).
dialogType INTEGER Dialog style(always pass 1 for this parameter).
x1 INTEGER Top left X coordinate of custom dialog window.
y1 INTEGER Top left Y coordinate of custom dialog window.
x2 INTEGER Bottom right X coordinate of custom dialog window.
y2 INTEGER Bottom right Y coordinate of custom dialog window.

Remarks

Note: deprecated from VW 9+: use CreateLayout.

Example

VectorScript

BeginDialog(1,1,TLeft,100,BRight,SCH);

Python


Version

Availability: from All Versions. Deprecated from VW 15+.