VS:BeginContext

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use this function in conjuction with EndContext to starts logging changes that are made until the EndContext is reached.

PROCEDURE BeginContext;
def vs.BeginContext():
    return None

Remarks

If you do not use this construct and you create a temporary plug-in object that itself creates a new class, the new class will remain even after you delete the temporary plug-in object.


Use this to begin a logical block of code that creates construct geometry that you intend to delete yourself, and which you don't need to be added to the undo list. For example, if creating a temp symbol for use in a symbol display control, use this so VW won't bog down adding all of the symbol geometry to the undo list.

Version

Availability: from VectorWorks 12.5

See Also

VS Functions:

VS:EndContext

VS Functions: [[VS:EndContext]]