VS:BeginColumn: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure BeginColumn creates a column object in a VectorWorks document using 2D object creation procedure calls to define the "template" for the column object.

After specifying object procedure calls to define the column, you should call EndGroup to complete the column definition and create the actual object.

PROCEDURE BeginColumn(
columnDistance :REAL);
def vs.BeginColumn(columnDistance):
    return None

Parameters

columnDistance REAL Height of column.

Remarks

BeginColumn takes the group of objects that follow, until there is an EndGroup, and converts them into a column with height equal to column distance.

[sd 8/17/98]

Example

VectorScript

BeginColumn(12');
Oval(2',2',6',6');
EndGroup;

Python

vs.BeginColumn(12*12)
vs.Oval(2*12,2*12,6*12,6*12)
vs.EndGroup()

Version

Availability: from MiniCAD7.0