VS:AutoKey/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ファンクションキー以外のキーが押し続けられていれば、TRUEを返し、同時に押されたキーのASCIIコードを返します。

FUNCTION AutoKey(
VAR asciiCode :LONGINT) : BOOLEAN;
def vs.AutoKey():
    return (BOOLEAN, asciiCode)

Parameters

asciiCode LONGINT 押されたキーのASCIIコード

Example

WHILE NOT AutoKey(keyHit) DO
BEGIN
     SysBeep;
     SysBeep;
END;
Message('The key pressed was ',keyHit);

Version

利用可能バージョン: MiniCAD