VS:AttachDefaultTextureSpace

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure AttachDefaultTextureSpace deletes any pre-existing space attached to the referenced object and creates a new one with the default object texture.

PROCEDURE AttachDefaultTextureSpace(
obj :HANDLE;
partID :INTEGER);
def vs.AttachDefaultTextureSpace(obj, partID):
    return None

Parameters

obj HANDLE Handle to object.
partID INTEGER Part ID (pass 1 for non-supporting objects).

Remarks

Deletes any pre-existing space attached to the object (with the specified part ID), creates a new one with the default value for this type of object, and attaches the texture space to the object.

Version

Availability: from VectorWorks8.0