VS:AssociateLayerWithStory

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Associates a Layer with a Story. When a Layer is associated with a Story, the Layer's elevation is displayed relative to the Story elevation. If the elevation of the associated Story is changed, the elevation of the Layer changes with it.

FUNCTION AssociateLayerWithStory(
layer :HANDLE;
story :HANDLE) : BOOLEAN;
def vs.AssociateLayerWithStory(layer, story):
    return BOOLEAN

Parameters

layer HANDLE The Layer to associate.
story HANDLE The Story to associate.

Return Value

Whether the Layer was successfully associated with the Story. This will fail if there is already another Layer associated with the Story that has the same Layer Level Type as the Layer passed in.

Example

VAR

success:BOOLEAN;
story:HANDLE;
layer:HANDLE;

BEGIN

story := GetObject('4th Floor');
layer := GetObject('Plan 4');
success := AssociateLayerWithStory(layer, story);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetNumStories | VS:GetStoryOfLayer | VS:CreateStory

VS Functions:

[[VS:GetNumStories]] | [[VS:GetStoryOfLayer]]

| [[VS:CreateStory]]