VS:Area

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the area of an object. If more than one object matches the search criteria, the function will return the sum of all the matching object areas.

FUNCTION Area(
c :CRITERIA) : REAL;
def vs.Area(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

totalA:=Area((C='Plywood')and(L='First'));
{returns the area of all objects in class 'Plywood' on layer 'First'}

Python


Version

Area is obsolete as of VectorWorks12.5


Availability: from All Versions