VS:AppendRoofEdge/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した屋根に、新しい縁を追加します。

PROCEDURE AppendRoofEdge(
theRoof :HANDLE;
edgePt :REAL;
slopeAngle :REAL;
projectionDistance :REAL)Coordinate); eaveHeightDistance:REAL (Coordinate));
def vs.AppendRoofEdge(theRoof, edgePt, slopeAngle, projectionDistance, eaveHeightDistance):
    return None

Parameters

theRoof HANDLE 屋根のハンドル
edgePt REAL 屋根の縁の座標
slopeAngle REAL 傾斜角度
projectionDistance REAL (Coordinate) 軒の張り出し距離
eaveHeightDistance REAL (Coordinate) 軒の高さ

Example

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,9.52627");
AppendRoofEdge(roofHandle,-77'10",-25'3.18078",#45d0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",-25'3.18078",#45d0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-41'2",21'4.81922",#45d0'0",2'0",10'0");
AppendRoofEdge(roofHandle,-77'10",21'4.81922",#45d0'0",2'0",10'0");
shedID := CreateShedDormer(roofHandle);
SetShedAttributes(roofHandle,shedID,TRUE,6'0",10'0",2'0",#8d0'0");
SetDormerAttributes(roofHandle, shedID, 3,18'4",TRUE,3'0",63,FALSE,3'0");
SetDormerThick(roofHandle, 2",1.83333");

Version

利用可能バージョン: VectorWorks8.0