VS:AppendRoofEdge: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (As of Vw 15, ResetObject() is required after creating a roof object.)
 
m (1 revision)
(No difference)

Revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function AppendRoofEdge creates a new edge in the referenced roof object.

PROCEDURE AppendRoofEdge(
theRoof :HANDLE;
edgePtX,edgePtY :REAL;
slopeAngle :REAL;
projectionDistance :REAL;
eaveHeightDistance :REAL);
def vs.AppendRoofEdge(theRoof, edgePt, slopeAngle, projectionDistance, eaveHeightDistance):
    return None

Parameters

theRoof HANDLE Handle to roof.
edgePt REAL Definition point of roof edge.
slopeAngle REAL Slope of roof edge.
projectionDistance REAL Eave overhang.
eaveHeightDistance REAL Eave height.

Remarks

Vertex is appended to the end of the list of vertices. Vertices define the outline of the roof. Vertices must progress in a counter clock wise direction, when viewed from a top view, otherwise the roof cannot be built.

edgePt: Coordinate point for this edge slope: pitch of this roof edge projection: eave overhang eaveHeight: eave height

Example

Template:CreateRoofOb

Version

Availability: from VectorWorks8.0