VS:AngularDim

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure AngularDim creates an angular dimension in the document.

Bit code values for dimension flags can be found in the VectorScript Appendix.


  • Angular Dimension

PROCEDURE AngularDim(
startPtX,startPtY :REAL;
endPtX,endPtY :REAL;
vert1X,vert1Y :REAL;
textOffsetDistance :REAL;
arrow :INTEGER;
textFlag :INTEGER;
posAngle :REAL);
def vs.AngularDim(startPt, endPt, vert1, textOffsetDistance, arrow, textFlag, posAngle):
    return None

Parameters

startPt REAL X-Y coordinates of dimension start point.
endPt REAL X-Y coordinates of dimension end point
vert1 REAL X-Y coordinates of dimension arc center.
textOffsetDistance REAL Offset from dimension arc center (radius of the dimension arc).
arrow INTEGER Dimension arrowhead style flag.
textFlag INTEGER Dimension text style flag.
posAngle REAL Position angle of dimension text(from start). Auto position text overrides this value.

Example

VectorScript

AngularDim(1 1/2",3/8",-1/4",-1/2",7/8",-1/2",1.7001838",771,770,#35d 32'16");

Python


Version

Availability: from All Versions