VS:AngDialog3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function AngDialog3D displays a dialog box which requests the user to enter three angle values. AngDialog3D will accept angle values in any supported angle format.

PROCEDURE AngDialog3D(
displayStr :STRING;
xStr :STRING;
yStr :STRING;
zStr :STRING;
VAR xAngleResult :REAL;
VAR yAngleResult :REAL;
VAR zAngleResult :REAL);
def vs.AngDialog3D(displayStr, xStr, yStr, zStr):
    return (xAngleResult, yAngleResult, zAngleResult)

Parameters

displayStr STRING Dialog user prompt string.
xStr STRING Default value for input field.
yStr STRING Default value for input field.
zStr STRING Default value for input field.
xAngleResult REAL Returns user input X value.
yAngleResult REAL Returns user input Y value.
zAngleResult REAL Returns user input Z value.

Example

VectorScript

AngDialog3D('Enter the angle values:','0','0','0',x,y,z);

Python

x,y,z = AngDialog3D('Enter the angle values:','0','0','0')

Version

Availability: from All Versions